By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

SVG Image Producing Broken Links in WP

I

ianholl

New Member
I've created an image using Inkscape and inserted it using the Elementor WP Custom HTML widget. The links are clickable but they will not open the linked webpage. The SVG image works fine in a browser, and the windows links work fine if I right-click the link and open in a new tab or new window. It just will not work properly when left clicking the link.

I've used the following code: <img src="h t t p : / / domainname.com/wp-content/uploads/2020/01/image.svg" class="style-svg"/

I've tried resizing the image to no avail. I've spent a lot of time trying to resolve this issue but nothing seems to work. Help much appreciated!

Regards,

Ian
 
elementor official
I

ianholl

New Member
Okay, I've resolved the issue. Turning off 'Image Lightbox' in Elementor's Site Settings fixes the issue.
 
elementor official
A

Agemo

New Member
On the point of SVG's, do they not pose a bit of a security risk in WordPress, and as such are not natively supported?
 
elementor official
I

ianholl

New Member
As far as I am aware SVG images can contain malicious code. However, the SVG image that I have added to my website was created by myself using InkScape so I know it is clean
 
elementor official

Latest posts

Other Elementor Resources

elementor official
elementor official
Top