By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

Styling problems after migration

Timtim

Timtim

New Member
Hello,

I recently migrated a Wordpress website from a sub-domain to the main domain. The problem now is that on some pages the CSS is not working properly. Only some of the CSS works on some pages.
What makes it weirder is that when I edit a page with the Elementor editor, all the styling is there and the whole website looks like it should. Making a minor change and updating the page doesn't do anything unfortunately.

I have replaced the url's, regenerated the files (using the Elementor tool) and cleared my cache. This problem occurs on the different devices I tried it with.

Is there anything I can try to fix this problem?

Thanks in advance,
Tim.
 
elementor official
sms-design

sms-design

Member
What process did you use to migrate your site?

Download EPIC Browser and confirm it's the same with a clean browser
 
elementor official
Timtim

Timtim

New Member
What process did you use to migrate your site?

Download EPIC Browser and confirm it's the same with a clean browser
I have used the steps described in the article by WPBeginner with the title "How to Properly Move WordPress From Subdomain to Root Domain" Sorry, I can't place a link in this message apparently, but I hope you can find it on Google this way.

The problem occurs on all devices I used to check the website with. So on iPhone, Chrome and several other PC's of other people. So I'm quite sure the problem is something with the website.

Thank you for the reply :)

Edit: I will summarize how I migrated the website to the main domain so you don't have to search (I'm kind of a noob so forgive me if this is the absolute wrong way to do it):

1. Backed up the website within wordpress when it was still on the subdomain
2. Downloaded the wordpress files and folders using WinSCP.
3. Deleted the website that was on the main domain using the same software (after backing it up)
4. Added "
define('WP_HOME','http://example.com');
define('WP_SITEURL','http://example.com');
"
to the wp-config.php file of the new website (example being replaced with the new url of course).
5. Got the website up and running on the main domain after uploading the files to the public_html folder.
6. Replaced the url's using the Elementor tool
7. Regenerated files.

Everything seems to work fine except for the fact that I don't see the Elementor styling on the pages, although I do see the styling when editing with Elementor.

Looking forward to your response :)
 
elementor official
Last edited:
sms-design

sms-design

Member
Do you still have a copy in the sub domain?

You can post your url like **mywebsite.com/mypage
 
elementor official
Timtim

Timtim

New Member
Do you still have a copy in the sub domain?

You can post your url like **mywebsite.com/mypage
Yes, I have the WP_folders and files on my pc. (Please see my first reply, I edited it so that you can see the things I did to migrate it).
 
elementor official
sms-design

sms-design

Member
If your Ok with editing your Database via cpanel you need to chnage the site urls because they will still be pointing @ the sub domain.

If you not OK with SQL run Velvet Blues Urls plugin to change from the old sub > to new domain

And then remove the define in config

You can also export a copy of your SQL DB and do a find replace for old sub > new domain URL
 
elementor official

Latest posts

Other Elementor Resources

elementor official
elementor official
Top