By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

QUESTION: Archive template displaying incorrectly on page

spinach

spinach

New Member
I am trying to set up a blog page on my website and used an Archive template to create a Blog Archive. When editing on the template everything shows up as it should - my draft posts are channelling through and displaying correctly. However, when I add the shortcode to a page so I can display it on the site, all of my posts disappear and are replaced with a link to the 'Blog' page... which is the page I am already on!

Hard to describe so hopefully you'll be able to tell what I mean from these photos. Does anyone know what is going on?


How I would like it to display (and how it is displayed when editing the archive template):
Screenshot 2021-01-06 at 14.32.31.png


How it displays when I add the shortcode to the 'Blog' page:
Screenshot 2021-01-06 at 14.33.23.png



Many thanks in advance!
 
elementor official
Last edited:

Latest posts

Latest Products

Other Elementor Resources

elementor official
elementor official
Top