By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

Please help me, I must be stupid

Timothy Barry

Timothy Barry

New Member
I am fairly new to elementor, and wordpress sites. I recently watched a couple of tutorials on building a single product page template with elementor. That was successful. The problem I am having is making me look like an idiot. When I create a new page to use the template, I insert the template and it inserts fine. But the problem is how am I suppose to link the template to a certain product. I can't figure it out. Please help me figure this out.
 
elementor official
sms-design

sms-design

Member
Go back to your template and edit the conditions ie: products in a category or just a single product by name

Next to your page update button (small chevron) click = Display Conditions

 
elementor official
Timothy Barry

Timothy Barry

New Member
By the way, I did look at the video and set the conditions to categories.
 
elementor official
sms-design

sms-design

Member
When you say inserting the template on the product page what are you doing?
 
elementor official
Timothy Barry

Timothy Barry

New Member
Here is what I am going to do. I will list step by step what I am doing, with screen shots. The first screen shot is the actual template that I made. The conditions are set to product. The next thing I do is open the page I want to put it on. The second image is the the product page ( before clicking edit with elementor ). Then next image is after clicking edit with elementor. Then I click on the gray icon that says add template. Then I click on insert. The template that I am using is single product v2.4 The last image is what I get. I really need some help with this. I am getting very discouraged, and am close to giving up on this store project.
 
elementor official

Attachments

sms-design

sms-design

Member
Most page builders operate a theme builder based on templates that produce layouts based on pages - posts - products.

Each post - product have 2 associated templates single & archive basically explained single is just a singular item - archive is them all group together on one page.

So Woo has these posts type single & archive so single is a product & achieve is products displayed in a grid.

The achieve collects all the singular posts and displays them on it's achieve page.

I can see where your going wrong but what you have looks VERY good for a first go at designing a website it's just in the wrong places. The last video is three hours but it's good

 
elementor official
Timothy Barry

Timothy Barry

New Member
Thanks for the help. Much appreciated. I will watch the videos, and let you know the outcome.
 
elementor official
sms-design

sms-design

Member
As I have never done a graphic header/website based on guns (not a lot of call in uk) I kind of came up with this. :)

The fonts not a direct match but.................
baywatcharms-logo-001.jpg


But using your image from this page http://baywatcharms.com/what_is_cerakote.php
 
elementor official
Koni Kodes

Koni Kodes

Member
Hi, Did you create the actual product? I had this same problem when I first began.
On your dashboard you should see Products under WooCommerce
1580572344608.png

When you click on the Products tab, you should see the choice to Add New:
1580572439946.png

This will take you to a page that allows you to input all the product information for a single product.

Then the Editor will know to connect to the product name and sort by category.
 
elementor official
Timothy Barry

Timothy Barry

New Member
Okay, I took some time to re-group. This is what I have come up with. I think I have the template deal worked out, and it looks pretty good to me. The issue I am have now is as follows. This is a variable product, when I get the template in place there is one are where it show kind of a duplicate. if you look where you would make your selection, the selection on the right with out the background should not be there. I have exhausted the ideas of what I thought would work. Can anyone help?? Here is a link to the actual page.
 
elementor official

Attachments

Koni Kodes

Koni Kodes

Member
Do you want to remove the additional data table?

If you are in chrome, right click that area and choose Inspect. You should be able to see the class name of that section.

Then in Elementor, on the section that holds the product info, go to the Edit section Advance tab. In the custom css type:
.[classname] {
display: none;
}
 
elementor official
Timothy Barry

Timothy Barry

New Member
I have tried the inspect. I can't locate the right classname to make it stick. When I do find one the works, it gets rid of both of them.
 
elementor official

Latest posts

Other Elementor Resources

elementor official
elementor official
Top