By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

Navbar jerks after klick

T

Tina_A

New Member
Hello,

I do have a problem with the nav menu widget on our website. Some navigation points jerk after klicking/ after loading the new page. Can someone help me with this?


Thanks a lot!
 
J

Joanetta

New Member
Tina, I have exactly the same issue. After looking at your website, I see that the jerks happen only on the dropdown menus. This is exactly how my navigation menu is behaving. I have rebuilt this menu 3 times with exactly the same results. Does anyone have a fix?
 
shaunm

shaunm

New Member
@Joanetta please share your site. For Tina's site, it seems to be caused by how she has the page structured, specifically the left column that is the full height of the page. You may want to check out this video by Elementor on optimizing use of elements and page structure to reduce CLS (Content Layout Shift)
 
J

Joanetta

New Member
The system won't let me include a URL because I've not posted 10 comments yet :)

Please a http:// and a .com to this:

phillipps.sg-host
 
shaunm

shaunm

New Member
I'm not seeing the CLS or jerking when clicking on a drop down menu item. Is there a specific link you are seeing this on?
 
shaunm

shaunm

New Member
One other thing I noticed and not sure if this causing the jerking when clicking on the drop down menu. You have mixed content on the page - specifically the custom fonts are all http and should be https. You can fix this in two different ways. First, go to your Custom Fonts and re-select the font file, making sure the file name is https. Another way is to go to Elementor>Tools>Replace URL and do a search / replace of your domain url. Enter your domain with http and then in the next field to the right, enter your domain with https. Your custom fonts are not showing when I view your website.
 
J

Joanetta

New Member
Shaunm, thank you! I'm seeing the shift on all the dropdown menus - Performance Tours, Theme Tours, MUN UN Conferences, Payment Info. When I move from left to right clicking on each dropdown, the Performance Tours doesn't shift. But the other three dropsdowns do. Then if I move back across the menu from right to left, all the dropdowns shift, including Performance Tours. Thank you for the information about mixed content and custom fonts. Haven't had much experience yet with custom fonts. This could certainly be part of the issue.
 
shaunm

shaunm

New Member
You're welcome, let me know if after fixing the font issue, the problem persists.
 
shaunm

shaunm

New Member
Hi @Tina_A thanks for sharing this post. I think its worth a try. WP Rocket is an excellent caching plugin, so even if it doesn't resolve this issue, it can help speed up your website. There is a free version of Asset Cleanup, so you may want to start there but not sure that will help with this issue.

I know this isn't fixing the issue (which is really minor to be honest, but understandably annoying) - have you considered using a page transition plugin like wordpress.org/plugins/loftloader/ ? It will essentially hide the entire page behind a transition animation (i.e. Loading) while the page loads, so you shouldn't see the menu jump. Hope this helps, cheers.
 

Latest posts

Latest Resources

Other Elementor Resources

elementor official
Top