By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

Question Nav Menu widget doesn't show on all pages

A

AllAboutVenice

New Member
I'm not a techie and that's one of the reasons why I love Elementor.
But now I'm lost. Here's the thing...
I recently purchased the Pro-version. The two things that made tip over were the nav menu and the post-widget.
I've created a nice sticky, transparent nav menu, responsive for mobile and in every way very cool. So far so good.
It's just that it shows only on the page where I created it, the main page. Nowhere else.
I've tried to just put in the widget, and I've tried creating a template, but nothing.
I run Generalpress.
In Generalpress customize I've had to tick no-menu. Otherwise, it shows two menus, the Elementor menu and the Generalpress one. Anyway, the Elementor menu doesn't show on the other pages, no matter what.
I've read thousands of helps and looked at loads of youtube videos, but no one seems to have ever had this problem.
I'm sure it's something I've overlooked, but if someone has any idea, please answer.
Thanx a million in advance... :(
 
elementor official

Latest posts

Other Elementor Resources

elementor official
elementor official
Top