By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

MailChimp field mapping

C

cjfountainvo

New Member
I'm having issues with mapping the fields in a popup. The integration is created with MailChimp and Elementor sees my account and my list/audience. It even pulls in the fields, but when you go to the dropdown to select the field to map to, the only option is "email". Are there known bugs with MailChimp integration?
 
elementor official
B

Bachuss

New Member
I hope someone has an answer to this question as I am having the same problem.
 
elementor official
F

foxglove

New Member
I also am having this problem, & if I submit the form anyway, I get a very unhelpful message that an error occurred.
 
elementor official
RichW

RichW

New Member
I was having the same issue but think I've figured it out.

  • In Elementor editor select the form you want to edit.
  • open the Form Fields section
  • Expand the first form field and click on advanced
  • enter an ID in the ID field.
I'm not sure if it makes a difference what you use as the ID. I used the same as MailChimp as found on their form "FNAME" and "EMAIL" and I set the field label to be the same as the ID.

Enter an ID for all the fields on your form and the should all appear in the dropdowns field mapping section.
 
elementor official
I

Iherdez91

New Member
I was having the same issue but think I've figured it out.

  • In Elementor editor select the form you want to edit.
  • open the Form Fields section
  • Expand the first form field and click on advanced
  • enter an ID in the ID field.
I'm not sure if it makes a difference what you use as the ID. I used the same as MailChimp as found on their form "FNAME" and "EMAIL" and I set the field label to be the same as the ID.

Enter an ID for all the fields on your form and the should all appear in the dropdowns field mapping section.

Thank you! This solved it.
 
elementor official
S

SteveH

New Member
I am having the same issue. I am using just first name and email, and set the field ID names in Elementor to FNAME and EMAIL to match the mailchimp field tag values shown when looking at the mailchimp form builder tool.

Regarding "Actions after submit", If I turn off the mailchimp action in Elementor, both the email action and redirect action work fine and I end up at my thank you page. As soon as I enable mailchimp again, nothing works and I do NOT get the message saying the form was submitted successfully, nor does the redirect take place. On a samsung smartphone I get a Red X after trying to submit, but on a windows 10 machine with Chrome, no error, no red X.

Is there any Wordpress.org or Elementor logging left behind on my site somehwere or from my WP admin console??

If I also go into Integration settings under Elementor->Settings and then the Integrations tab and specify my Mailchimp API key, and then click validate API key, I so end up with the green check mark, so it appears to work.

On the Mailchimp side, when checking Integrations, I do not see anything for Elementor, but there is a WordPress integration. Should I go through that process? It generates a small piece of code, and suggests that needs to be pasted into the WordPress theme header.php file.

Any thoughts on how to further troubleshoot this? Thank you.

I am using the free versions of mailchimp and the Elmentor plug in for Wordpress if that matters.
 
elementor official
S

SteveH

New Member
I am having the same issue. I am using just first name and email, and set the field ID names in Elementor to FNAME and EMAIL to match the mailchimp field tag values shown when looking at the mailchimp form builder tool.

Regarding "Actions after submit", If I turn off the mailchimp action in Elementor, both the email action and redirect action work fine and I end up at my thank you page. As soon as I enable mailchimp again, nothing works and I do NOT get the message saying the form was submitted successfully, nor does the redirect take place. On a samsung smartphone I get a Red X after trying to submit, but on a windows 10 machine with Chrome, no error, no red X.

Is there any Wordpress.org or Elementor logging left behind on my site somehwere or from my WP admin console??

If I also go into Integration settings under Elementor->Settings and then the Integrations tab and specify my Mailchimp API key, and then click validate API key, I so end up with the green check mark, so it appears to work.

On the Mailchimp side, when checking Integrations, I do not see anything for Elementor, but there is a WordPress integration. Should I go through that process? It generates a small piece of code, and suggests that needs to be pasted into the WordPress theme header.php file.

Any thoughts on how to further troubleshoot this? Thank you.

I am using the free versions of mailchimp and the Elmentor plug in for Wordpress if that matters.
Update.. in WP, under Elementor ->System Info there is a log. If I clear it , reproduce the issue, I see this error below. Hopefully this helps. (note I changed http below to htttp otherwise, this forum would not allow me to include the link :) )

JS: showing 1 of 1
JS: 2020-09-23 13:00:10 [error X 1][htttp://mysite.com/wp-content/plugins/elementor/assets/js/common.min.js?ver=3.0.8:2:128443] Cannot read property \'error\' of undefined
 
elementor official

Latest posts

Other Elementor Resources

elementor official
elementor official
Top