By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

Question Icons not showing in custom icon library

A

ABClaude

New Member
Hey everyone,

Hopefully you can help me.
For the website i'm working on I'm using custom icons for the first time.
However when i upload the Fontello .zip file to the icon library they appear to be blank and I can only see the name.

When I try to input them into the site, the icon set is visible in the menu but when I click it, it stays on the current tab (f.e. all icons).

Anyone has experienced this before or knows a fix?

Thanks!
 
cedwards

cedwards

New Member
I am experiencing this problem as well. Was there ever a resolution?
 
D

danbro

New Member
Facing same problem :-(
Imported fontello-icon font...
did like described in several how tos...
icons are not visible just the cards are visible bit no icons on them

please can anybody help
 
C

Croft3242

New Member
It usually happens when you have colored .SVG icons zipped up with single color icons. Try re-zipping at Fontello without the colored SVG icons and see what happens when you import.
 
B

BAHSO

New Member
It usually happens when you have colored .SVG icons zipped up with single color icons. Try re-zipping at Fontello without the colored SVG icons and see what happens when you import.
Hi There

I have the same issue and tried your fix. It does not work. Any other ideas on how this can be fixed?
 
R

Raauw

New Member
Same issue, the icon shows fine in Fontello, only name in Elementor icon set section. and in the icon library it shows nothing.
 
T

Tarif Chandan

New Member
Hello,
I was using Fontastic and had the same problem. But when I tested the icon sets on Local, the custom icons were no longer blank. So, I went to my website which was using SSL (HTTPS) and checked whether my WordPress General Setting's "WordPress Address (URL)" and "Site Address (URL)" were using HTTPS. Turned out they were using HTTP. So, when I changed them to HTTPS and uploaded a new icon set, the icons were showing up perfectly.

So, in simple words, if you are using SSL (HTTPS),
Go to WordPress Dashboard > Settings > General and make sure "WordPress Address (URL)" and "Site Address (URL)" are also using HTTPS.

Hope it helps!
 

Latest posts

Latest Resources

Other Elementor Resources

elementor official
Top