By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

How to view page html source code created with Elementor

D

drosberg

New Member
Hi all, I'm wondering if there's a way to view (and modify) page source code created by Elementor? I've installed a SSL which isn't working properly because I have images on the page with a URL starting with http:// rather than https://? , or at least that's message I'm getting back when I check the site with 'whynopadlock.com'. I think I just need to change the image http to https, but there's I can't find a way to view and edit the page code created with Elementor. I've tried the obvious...using the WordPress theme editor, but can't seem to find the homepage that I created.
Hope this makes sense and thanks in advance.
drosberg
mixed content error.PNG
 
elementor official
Community

Community

Administrator
Staff member
Elementor provides you with a search and replace tool. Make a backup of your site and database first.

Then goto the admin panel - elementor - tools - replace URL

Then in the "old url" field enter your domain name with http.

In the "new url" field enter your domain name with https.

Make sure you do not enter any trailing slashes, spaces or anything else at the end and beginning of the domain.

Once the process is done it should replace all assets and mentions of your previously non-ssl URL to the new https version.
 
elementor official
tonyamsler

tonyamsler

New Member
Hey Don,

I'm having the same issue. In the replace tool, did you simply use http > https?

Then in the "old url" field enter http.

In the "new url" field enter https.

not using the full domain url?

thanks

Tony
 
elementor official
D

drosberg

New Member
Hi Tony yes I just replaced the http with https and that solved the problem.

Good luck

Don
 
elementor official
tonyamsler

tonyamsler

New Member
Don,

When I did this an alert popped up "The from and to must be a valid url". Does not appear to allow simply changing http to https.

Did you also grab the url from WhoNoPadlock to do a replace using this tool?

Tony
 
elementor official
tonyamsler

tonyamsler

New Member
Don,

No need to reply. This worked fine and now have the "padlock" on our website.

thanks for your assistance.

Tony
 
elementor official
F

firstreview

New Member
I've tried something like this before, but it didn't work
 
elementor official

Latest posts

Other Elementor Resources

elementor official
elementor official
Top