By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

Failed to connect to Elementor library when connecting with Elementor Accout for wordpress

N

Nukro95

New Member
Hey,

so i am working on a Website right now with Wordpress and planned to use the Elementor Builder. Whenever i try to load in a Template, it tells me to connect my Elementor Account with the Library. As soon as i connect it, it tells me that there was an Error to connect with the Library even though i can see all different possible Templates and Wordpress tells me that i am connected to the Elementor Library and that it is synced up. My hosting service is Plesk, so maybe the don't allow access somehow? I can't figure out what the problem is, maybe someone had a similar problem.

Thank you in advance and if you need any other information let me know.
 
elementor official
D

delej4

New Member
i got exactly the same problem....
Did u found an answer ?
 
elementor official
S

Si_1990

New Member
My problem as well since yesterday. I've updated the elementor plugin, but that didn't help. Suggestions are very welcome!
 
elementor official
J

ja.wi91

New Member
I experience the same problem. Does someone already now the solution?
 
elementor official
Onboardl Digital

Onboardl Digital

New Member
Having the same problem. Have to synch the template library over. Getting an error message when trying to insert a template.
 
elementor official
Community

Community

Administrator
Staff member
Is there any hosting related caching which you can clear ?

We've come across this a few times, but we typically disconnect our licence, then re-activate the licence on that site. Clear all hosting and site/plugin caches and the library works again.
 
elementor official

Latest posts

Other Elementor Resources

elementor official
elementor official
Top