By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

Question EMBEDDED YOUTUBE THUMBNAILS ONLY SHOWS FOR SOME VIDEOS

cbtisrael

cbtisrael

New Member
i have a podcast which i also show on youtube. i am using identical post templates for each episode, but only some of the embedded videos show a video thumbnail when loading the page.

for example, this post shows a thumbnail for the video:
https://
elementor.cbtisrael.co.il/2020/02/22/%D7%A4%D7%A8%D7%A4%D7%A7%D7%A6%D7%99%D7%95%D7%A0%D7%99%D7%96%D7%9D/
(here’s the embedded youtube video: youtube.com/watch?v=bfCaYU6cy9w)

while this post does not show a thumbnail for the video:
https://
elementor.cbtisrael.co.il/2020/02/24/%D7%91%D7%A8%D7%99%D7%90-%D7%91%D7%A8%D7%90%D7%A9-%D7%A2%D7%9D-%D7%93%D7%A8-%D7%90%D7%95%D7%94%D7%93-%D7%94%D7%99%D7%9E%D7%A0%D7%A2%D7%95%D7%AA-%D7%95%D7%99%D7%93%D7%90/
(here’s the embedded youtube video: youtube.com/watch?v=aXNgnPHtEQs)

why do some videos have a thumbnail and others don’t?
 
elementor official

Latest posts

Other Elementor Resources

elementor official
elementor official
Top