By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

Deprecated: Elementor\Scheme_Typography

mwoodpatrick

mwoodpatrick

New Member
I just recreated one of my sites based on an old duplicator package and then updated the site to WordPress 5.6.1 and the latest version of the plugins and now I get the error:

1613079663199.png


In grepping the code for this I saw it in premium-addons-for-elementor & essential-addons-for-elementor-lite even though I have the latest versions of these plugins. I tried deactivating & deleting these plugins and the problem went away. I readded "Essential Addons for Elementor" 4.5 and I get the same error again and I see the line:

use \Elementor\Scheme_Typography;

at line 12 in

plugins/essential-addons-for-elementor-lite/includes/Extensions/Table_of_Content.php

Please advise
 
Space of Ahmad

Space of Ahmad

New Member
I disabled essential addons extensions and the error went away.
Go to Essential Addons Settings then to the extensions tab and try to disable what you don't need or disable them one by one till you get rid of the error.
 
N

Nill

New Member
Desativei as extensões de complementos essenciais e o erro foi embora.
Vá para Configurações de Complementos Essenciais e depois para a guia de extensões e tente desabilitar o que você não precisa ou desabilitá-los um por um até se livrar do erro.
Cara fiz o que vc disse e deu certo, desativei a extensão "table contents" e resolveu o problema. Obrigada!
 
chinoh

chinoh

New Member
We had the same error on one client's side (and not others). Disabling the Essential Addons - Extensions tab stopped the error message.
 
M

Md Rafiqul Islam

New Member
Cara fiz o que vc disse e deu certo, desativei a extensão "table contents" e resolveu o problema. Obrigada!
Can please write again in english.. and I am not using Essential addon . I am an Elementor Pro user
 
H

Hans101

New Member
Hello,
Same issue here, not using Essential addons.
Hope someone will find a solution..

Cheers
 
ashrafulnoa

ashrafulnoa

New Member
Hello,
After updating, i see the following error.

Deprecated: Elementor\Scheme_Color is deprecated since version 2.8.0! Use Elementor\Core\Schemes\Color instead. in /home/bdenvironment.com/public_html/wp-includes/functions.php on line 5051

Deprecated
: Elementor\Scheme_Typography is deprecated since version 2.8.0! Use Elementor\Core\Schemes\Typography instead. in /home/bdenvironment.com/public_html/wp-includes/functions.php on line 5051

My Website: bdenvironment.com

How can i solve this issue? Can anyone please help me?
 
ashrafulnoa

ashrafulnoa

New Member
I disabled essential addons extensions and the error went away.
Go to Essential Addons Settings then to the extensions tab and try to disable what you don't need or disable them one by one till you get rid of the error.
I did but not solved.

My issue
After updating, i see the following error.

Deprecated: Elementor\Scheme_Color is deprecated since version 2.8.0! Use Elementor\Core\Schemes\Color instead. in /home/bdenvironment.com/public_html/wp-includes/functions.php on line 5051

Deprecated
: Elementor\Scheme_Typography is deprecated since version 2.8.0! Use Elementor\Core\Schemes\Typography instead. in /home/bdenvironment.com/public_html/wp-includes/functions.php on line 5051

My Website: bdenvironment.com

How can i solve this issue? Can you please help me?
 
R

Robert

New Member
I am also having this issue. I deactivated Essentials Add-on Pro and it did not solve the problem. I then changed my theme from Neve Pro to Hello theme by Elementor. That seems to have worked so far. The only support I received from Elementor was a link to this forum thread. Really frustrating.
 
Slav

Slav

New Member
I have also the same issue but with CrocoBlocks plugins, namly JetBlocks and JetSmartFilters. I have let CrocoBlock support know of the issue so hopefully they will have a workaround or release an emergency fix shortly.
 
F

faktor1

New Member
Hello Forum,

we also have the following error:

Deprecated: Elementor\Scheme_Typography ist seit Version 2.8.0 veraltet! Benutze stattdessen Elementor\Core\Schemes\Typography. in /html/hydropools_de/wp-includes/functions.php on line 5051

It appears in the middle of the page (see screenshot).

hydropools.de/whirlpool-swimspa/executive-trainer/

We use Crocoblocks Jet Blocks and JetSmartFilters.

What can we do in that case?

Thanks for your help in advance!

Kind regards
Frank
 

Attachments

  • hydropools-screenshot.jpg
    hydropools-screenshot.jpg
    77.3 KB · Views: 105
Slav

Slav

New Member
Hello Forum,

we also have the following error:

Deprecated: Elementor\Scheme_Typography ist seit Version 2.8.0 veraltet! Benutze stattdessen Elementor\Core\Schemes\Typography. in /html/hydropools_de/wp-includes/functions.php on line 5051

It appears in the middle of the page (see screenshot).

hydropools.de/whirlpool-swimspa/executive-trainer/

We use Crocoblocks Jet Blocks and JetSmartFilters.

What can we do in that case?

Thanks for your help in advance!

Kind regards
Frank
 
N

nicole583

New Member
I am also having the same error and I am sure if there are this many posts that many more people not posting are also having this issue. Can we get a solution? I do not have Essential add on.
Deprecated: Elementor\Scheme_Color is deprecated since version 2.8.0! Use Elementor\Core\Schemes\Color instead. in /home/customer/www/tracheostomyeducation.com/public_html/wp-includes/functions.php on line 5051
 
F

faktor1

New Member
Still waiting for a solution here. Kind of frustrating, that there isn't any reaction of the support-team.
 
F

faktor1

New Member
Meanwhile, we helped us by ourselfes. Thanks for nothing.

Elementor? Never again. There are too many good alternatives to accept this kind of "service".
 
B

Baggio

New Member
I disabled essential addons extensions and the error went away.
Go to Essential Addons Settings then to the extensions tab and try to disable what you don't need or disable them one by one till you get rid of the error.
Thank you Sir. I am on elem pro and disabled EA disabled as suggested now error is gone
 
brunofontaine

brunofontaine

New Member
After some research, this is what I did to solve the issue without disabling my plug-in. We are using the plug-in "Elemento Forms - All Contact Form Integration with DB for Elementor". Your plugins will probably have the same files structure and can be fixed in a similar way.

In my specific case:
Plugin Folder is "/wp-content/plugins/all-contact-form-integration-for-elementor/includes"
Filename is "contact-form-7.php"

Look for a line showing:
$this->add_group_control(
Group_Control_Typography::get_type(),
[
'name' => 'acfe_contact_form_submit_btn_typography',
'scheme' => Scheme_Typography::TYPOGRAPHY_1,
'selector' => '{{WRAPPER}} .acfe-contact-form-container input.wpcf7-submit',
]
);


Replace
'scheme' => Scheme_Typography::TYPOGRAPHY_1,
With
'scheme' => Core\Schemes\Typography::TYPOGRAPHY_1,

Problem gone. Since multiple plugins can have this issue, you will need to search which file has a similar line in your plugin folder. I would suggest that you search only the term "Scheme_Typography" in your files.
 

Latest posts

Latest Resources

Other Elementor Resources

elementor official
Top