By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Unofficial Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

95 second Loading time - GTMetrix Onload time

W

writegoodcode

New Member
Wordpress 5.5 broke quite a few plugins. The most annoying thing was trying to figure out what was wrong. After changing name servers, contacting the host, and disabling each plugin 1 by 1, changed to 20 20 theme & more. I found out Elementor was the issue. Once elementor is disabled, the site runs fine.

When I ran the site through GTmetrix the site wouldn't even load. It would time out. Now I have it so it fetches, but it takes 95 seconds Ontime speed. But the scripts finish in 2 seconds and an A score. When I run on Google Pagespeed it's fine and loads fast. Pingdom doesn't show a thumbnail but loads. You can tell something is off. None of my other sites that run Elementor are affected.

Contacted Elementor support (I'm a pro member) but they haven't responded after 12 hours. I have been troubleshooting all day.

Anyone else have this issue?
 
elementor official

Attachments

Latest posts

Other Elementor Resources

elementor official
elementor official
Top